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Introduction to KwikDraw
KwikDraw is a drawing program.    It is very different from a paint program, in that it is object
oriented.    This means that after drawing objects (such as rectangles, ellipses, lines, text, 
curves, polygons, or splines), you have the ability to select and modify them as independent 
entities.    In a paint program an object, once it is drawn, loses it's identity as an independent
entity.    Any editing capability in a paint program must thus treat all the objects as mere 
patterns of bits on the drawing surface.

The distribution disk contains several example drawings in files using the extension ".kwk".    
Select the "Open" option on the KwikDraw "File" menu to look at these example drawings.    
These examples illustrate how complex drawings can be produced as a conglomeration of 
simple objects such as lines, arcs, rectangles, polygons, ellipses, and spline curves, the 
fundamental building blocks provided by KwikDraw.    To get a feel for this take a close look 
at "train.kwk" and "car.kwk".

You may be thinking that it is a lot of work to build a complex drawing out of such simple 
objects.    However, you are not restricted to building your drawings solely out of the basic 
objects provided by KwikDraw.    The "Group" feature of KwikDraw allows you to create new 
building blocks out of more primitive ones.    For example, in a drawing of a car you may 
combine two circles to form a tire, along with several ellipses for a custom wheel.    The 
objects that make up the tire and wheel may be "Grouped" to form a more complex building 
block.    This "Tire and Wheel" object may be duplicated and reused in your drawing.    
"Grouped" objects may copied, moved, stretched, resized, flipped, filled, rotated, etc. just 
like the simple objects.    You may wish to create libraries of your own parts or components.    
KwikDraw includes a "Parts Library Browser" that will allow you to scroll through the parts in 
your library while working on a drawing.    For an example, try using the "Open As Library" 
option on the "File" menu, and select the file "logic.kwk."

KwikDraw also allows you to attach a text description to any object, including grouped 
objects and their components.    These descriptions may be viewed and edited on-screen or 
written to a text file.    This feature may be used to generate a parts list from your drawing.    
For an example, try selecting the "Write Descriptions" option on the "File" menu after loading
the drawing "landscp2.kwk."    For more information on using object descriptions, see 
Manipulating Object Descriptions.

Feel free to experiment with the example drawings.    Any changes you make to them will not
be permanent as long as you do not select "Save" from the "File" menu.



Help on KwikDraw Menus
File Menu
Edit Menu
Convert Menu
Layout Menu
Arrange Menu
Pen Menu
Font Menu
Size Menu



File Menu
New
Clears the drawing and sets the current filename to "noname.kwk" (displayed in the caption 
bar at the top of the drawing).

Open
Shows the disk directory and allows you to open a new file.    The Open dialog box will also 
allow you to change the current directory.

Open as Library
Shows the disk directory and allows you to open a KwikDraw file into a "Parts Browser" 
window.    Parts may be inserted from the Parts Browser using the "Insert from Library" option
on the "Edit" menu.    The "Open as Library" menu selection is deactive if a Parts Browser is 
already active.    For more informationon this, see Creating and Using Parts Libraries.

Save
Saves the drawing to disk under the current filename (as displayed in the caption bar at the 
top of the drawing).    If the caption bar is labelled "KWIKDRAW", then the current filename is 
actually "noname.kwk".

Save As
Allows you to save the drawing with a new filename.    The Save As dialog box will not allow 
you to change the current directory.    You can, however, save to a file in a different directory 
by prefixing the filename with a directory path.

Write Descriptions
Writes all object descriptions to a specified filename.    Allows you to save the drawing with a 
new filename.    You may write the descriptions to a file in a different directory by prefixing 
the filename with a directory path.    After writing the descriptions the Notepad text editor 
shipped with MS Windows will be launched with the specified file loaded for your review.    
Object coordinates are written with the object descriptions as an aid for cross referencing 
the descriptions in the file to objects on the drawing.

Print
Brings up the print popup menu.    You may want to set the printer orientation to match the 
drawing size entered in the "Drawing, Grid Size" dialog box (which is launched from the 
"Layout" menu).    To do this, use the "Setup" button on the print popup menu.    KwikDraw 
will automatically scale the screen drawing to the paper size of your printer.

Select Printer
This menu option allows you to change your default printer by launching the Printers portion 
of the Windows Control Panel.    To change printers, double-click on a new printer to make it 
the default.

Exit
Quits KwikDraw.    If the current drawing has been modified since last saved, then you will be 
asked whether you wish to save the changes before quitiing.



Edit Menu
Undo
Undoes the last change made to an object, or a set of objects.    Use this option to undo the 
following changes:    Moved objects, Scaled objects, Polygon vertex changes, Text changes, 
Curve extent changes, Line arrowhead changes, Rotations, Fill Pattern changes, Line style 
changes, and Font changes.    To Redo something that you have undone, simply select Undo 
again (Undo the Undo).    To undo a Flip operation, perform the Flip again.    To undo Group 
Objects, use Ungroup Objects (and visa-versa).    To undo Object Forward, use Object 
Backward (and visa-versa).    To undo Cut, use Paste (and visa-versa).    To undo Duplicate, 
use Cut or the Backspace or Delete keys.    Changes to object descriptions cannot currently 
be undone.

Cut
Cuts the currently selected objects into the Windows Clipboard.    Objects in the Windows 
Clipboard may be pasted into the current drawing, into a newly loaded drawing, into a 
drawing in another session of KwikDraw, or into any application that supports MetaFile 
formats, which includes most Windows based word processors and drawing programs.

Copy
Copies the currently selected objects into the Windows Clipboard.

Paste
If the Windows Clipboard currently contains any KwikDraw objects, then they will be pasted 
into the current drawing.    The objects will be pasted in a selected state so that you can 
easily move them about.

Show Clipboard
Launches the Windows Clipboard.    This is a convenient way to view or resize the contents of
the clipboard before pasting into another application.    For more information on this, see 
Transfer to Other Applications.

Delete
Removes the currently selected objects.    Use this option sparingly as there is no way to 
recover a deleted object.    You should use the Cut option instead unless you are already 
holding something important in the clipboard.    The <Del> and <Bksp> keys will also result 
in deletion of the selected objects.    The <Ctrl X> combination is safer as it results in a Cut 
(to the clipboard).

Insert From Library
Inserts the part currently displayed in the "Parts Browser" window into the current drawing.    
To open a Parts Library, use the "Open as Library" selection on the "File" menu.    The "Insert 
From Library" selection is only active when a Parts Browser window is active.    For more 
informationon this, see Creating and Using Parts Libraries.

Duplicate Object
Duplicates the selected items, leaving the newly created objects in a selected state.    If you 
move the duplicate object immediately after performing the duplicate, then KwikDraw will 
automatically remember the desired displacement for successive duplicates.

Edit Text Object
Allows you to edit a previously placed text object.    A single text object must be selected 
before this menu item can be used.    You can also edit a text object by double clicking the 
left mouse button on it.    Note that the description of a text object is different than the text 
of a text object.    The description may be edited by choosing the "Edit Description" option on



this menu or by selecting it and pressing the right mouse button.

Edit Poly (or Spline)
Selecting this item will toggle the "Edit Poly (or Spline)" mode on or off.    When checked, this
menu item indicates that you are currently in "Edit Poly (or Spline)" mode.    In this mode, the
vertices of polygon or spline objects may be altered by pointing at them, holding the left 
button down, and dragging the mouse.    In order to scale a Polygon or Spline object by 
stretching one of the corners, the "Edit Poly (or Spline)" mode must be turned off.

Extend Curve 
Selecting this menu item will toggle the "Extend Curve" mode on or off.    When checked, this
menu item indicates that you are currently in "Extend Curve" mode.    Curve type objects 
(curve, pie, or chord) are initially created as one quadrant of an ellipse.    In the "Extend 
Curve" mode, the endpoints of Curve type objects may be lengthened or shortened by 
pointing at them, holding the left button down, and dragging the mouse.    In order to scale a
curve object by stretching one of the corners, the "Extend Curve" mode must be turned off.

Edit Description
Allows you to edit the description of a previously placed object.    A single object must be 
selected before this menu item can be used.    You can also edit an object description by 
double clicking the left mouse button on it (except for text objects) or by selecting it and 
then pressing the right mouse button.



Convert Menu
The selections on this menu allow you to convert between Open Polygons, Closed Polygons, 
and Spline Curves.    The active options depend on the object currently selected.



Layout Menu
Show Grid
This menu item toggles the grid display on and off.

Snap to Grid
This menu item toggles the grid snap mode on and off.    When grid snap is on, you will only 
be allowed to draw, move, and stretch objects to the nearest grid points.

Constrain
This menu item toggles the Constrain mode on and off.    When Constrain is on, new objects, 
other than Lines or Polygons, will only be drawn with a one-to-one aspect ratio.    Thus only 
Squares will be drawn when using the Rectangle tool, and only Circles will be drawn when 
using the Ellipse tool, etc.    Line objects, and the line components of Polygon objects, will 
only be drawn horizontally, vertically, or at 45 degree angles in the Constrain mode.    When 
resizing or stretching objects, the Constrain mode will prevent you from changing the aspect
ratio of the object.    This means that changing the size of an object in one dimension can 
only occur with a proportionally equal change in the other dimension.    Constrain mode is 
especially helpful when resizing text objects.

Drawing, Grid Size
This menu selection allows you to alter the size of the drawing or the grid spacing.    All 
dimensions in the resulting dialog box are expressed in "logical" pixels, where a logical pixel 
corresponds to a screen pixel in the 100% zoom mode (in the 200% zoom mode, a logical 
pixel is two screen pixels in each dimension).    For more information on this see Changing 
the Drawing Size or Changing the Grid Spacing.

Show Coord
This menu selection will toggle the coordinate display window on and off.    The coordinate 
display window is placed on the title bar of the KwikDraw window and tracks the coordinate 
of your cursor when KwikDraw is the active application.

Zoom (25%-400%)
These menu items control the zoom level of the screen.    At a 100% zoom level, logical 
drawing pixels (the smallest increment of dimension in the drawing) correspond to screen 
pixels.    At 200% zoom level, a logical drawing pixel is two screen pixels in each dimension, 
with the result that the objects appear larger on your screen.    If you wish to focus in a 
certain area of your drawing, simply select an object that is in the general area prior to 
zooming in or out.    The selected object will be centered in the display after the zoom.    This 
will save you from having to search for your area of interest with the scroll bars after 
zooming.    When nothing is selected, the zoom will maintain the current center of the 
display.    You should try to do the bulk of your drawing at the 100% level, and reserve the 
zoomed in modes for detailed placement of objects that have already been drawn.    If you 
find that you require additional drawing area, then it is better to increase the size of your 
drawing (using the "Drawing, Grid Size" selection), rather than attempting to make smaller 
objects by working at a higher zoom level.



True Type Fonts

The True Type Fonts are    Arial, Courier, Tms Rmn, Wingdings, and Symbol.



Stroke Fonts

The Stroke Fonts are Roman, Modern, and Script.



Solid Colors

Solid Colors are those that can be obtained directly from your video hardware for each 
display pixel.



Dithered Colors

Dithered Colors are generated (by MS Windows) by placing display pixels with different solid 
colors adjacent to each other.    If you are standing far enough away from your monitor, your 
eyes will "mix" the adjacent pixels to give the effect of a color that your video hardware 
cannot otherwise generate directly.



Arrange Menu
Move Forward
This menu item will move the currently selected item on top of the first item found that 
overlaps it.    When multiple items are selected, this procedure is applied to each item in the 
order that the items were selected.    The results can be confusing since the next item Moved
Forward could undo the result of the last item Moved Forward.    Similar comments apply to 
the other Move selections.

Move Backward
Moves the currently selected item below the first item found that it overlaps.

Move to Front
Moves the currently selected item to the top of all items that overlap it.

Move to Back
Moves the currently selected item to the bottom of all items that it overlaps.

Flip Horizontal
Flips the selected items horizontally about their individual center points.    The items that 
make up a Grouped object will be flipped about the center of the Group, such that the entire 
object flips as a unit.

Flip Vertical
Flips the selected items vertically about their individual center points.    The items that make 
up a Grouped object will be flipped about the center of the Group, such that the entire object
flips as a unit.

Rotate
Rotates the selected items 90 degrees about their individual center points.    The items that 
make up a Grouped object will be rotated about the center of the Group, such that the entire
object rotates as a unit.

Group
Combines the selected object into a grouped object, which can be moved, stretched, flipped,
rotated, etc as a single entity.    Groups of Groups can be formed to an arbitrary number of 
levels.

Ungroup
Ungroups the selected Group objects back one level into independent entities.    Note that 
Ungrouping a Group of Groups takes you back only one level instead of all the way back to 
the base object types.



Pen Menu
The selections and dialog boxes launched from this menu are context sensitive.    When no 
objects are currently selected, this menu and its associated dialog boxes show you (and 
allow you to modify) the current defaults for Fill Patterns, Line Widths, Line Types, and Line 
Arrowheads.    When a single object is selected, the menu and dialog box items show and 
modify the attributes of only that object, WITHOUT changing the defaults that will be used 
for newly created objects.    When multiple objects or Grouped objects are selected, the 
menu and dialog boxes will show nothing checked, since the selected objects may all have 
different settings.    In this case, when you choose a menu or dialog box item, it will set the 
corresponding attribute of ALL currently selected items, again WITHOUT modifying the 
default attributes.

Fill
Launches a dialog box that allows you to change the Fill Pattern and the Fill Color for closed 
objects (rectangles, ellipses, closed curves, and closed polygons).

Line Style
Launches a dialog box that allows you to change the Line Width, Line Style, and Line Color 
for any object other than Text Objects.    Only solid lines may be given a width greater than 1 
in this dialog box.    If any of the dotted or dashed line styles is selected, the width will be 
forced to 1, and the width entry field on the dialog box will be disabled.

Arrow Style
Launches a dialog box that allows you to change the Arrowhead Style for Line Objects.

Arrows
These menu items only apply to Line objects.    The attributes of the selected object are 
shown as a check mark next to the Left Arrow or Right Arrow menu items (or both).    Any of 
the menu items Left Arrow, Right Arrow, No Arrows, or Both Arrows, may be chosen to alter 
the selected object.    The Left Arrow and Right Arrow items act as toggles.



Font Menu
This menu only applies to Text objects.    The selections are context sensitive.    When no 
objects are currently selected, this menu shows you (and allows you to modify) the current 
defaults for Font Type and Style.    When a single object is selected, the menu shows the 
attributes of only that object, WITHOUT changing the defaults that will be used for newly 
created Text objects.    When multiple objects or Grouped objects are selected, the menu will 
show nothing checked, since the selected objects may all have different settings.    In this 
case, when you choose a menu item, it will set the corresponding attribute of ALL currently 
selected items, again WITHOUT modifying the default attributes.

True Type Fonts
The first group of font types on this menu are True Type Fonts if you are running Windows 
3.1.    If you are running Windows 3.0, then these font selections will result in the older 
Raster Fonts.    Raster Fonts are not arbitrarily scalable, which can result in some displays 
that are not true to the printed output at zoom levels below 100%.    Raster Fonts are also 
not rotatable and are difficult to scale by grabbing a selection corner.    In other words, you 
should get Windows 3.1 if you haven't already.

Stroke Fonts
The second group of font types on this menu are Stroke Fonts.

Font Style
The last group on this menu controls the font style (Normal, Bold, Italic, or Underline).



Size Menu
This menu only applies to Text objects.    The selections are context sensitive.    When no 
objects are currently selected, this menu shows you (and allows you to modify) the current 
defaults for Font Size.    When a single object is selected, the menu shows the Font Size of 
only that object, WITHOUT changing the default that will be used for newly created Text 
objects.    When multiple objects or Grouped objects are selected, the menu will show 
nothing checked, since the selected objects may all have different sizes.    In this case, when 
you choose a size, it will set the corresponding attribute of ALL currently selected text 
objects, again WITHOUT modifying the default size.

You can also change font sizes by dragging one corner of the selection box, as discussed 
under Modifying Objects.    KwikDraw will try to maintain a reasonable aspect ratio for the 
font during this process.    You can help out by trying to scale the font equally in both 
dimensions or by turning the Constrain option on.



Help on KwikDraw Tool Bar
The KwikDraw Tool Bar is displayed vertically along the left edge of the drawing area.    The 
tool bar contains the Pointer Tool and an collection of primitive object Drawing Tools.    The 
Pointer Tool is used to select objects in preparation for any type of modification.    The 
Drawing Tools are used to draw primitive objects on the drawing surface.    KwikDraw will 
give you visual clues as to which tool is currently in use.    First of all, the current tool's 
button is displayed with a pushed-in look.    In addition, when a Drawing Tool is in use, the 
cursor will appear as a cross-hair instead of a pointer.    Different cursors are also used during
object movement and resizing.

Normally, after drawing an object, the Tool Bar will revert to the Pointer Tool with the object 
already selected.    This makes it convenient for you to immediately move or rescale the 
object.    If you would rather draw several object instances in succession without having to 
rechoose the tool, simply select the tool from the tool bar with a double-click of the left 
button or with the right button.    The pushed-in button will now appear with a dark black 
background as a reminder that you have selected it in the "sticky" mode.

Pointer Tool
Text Tool
Line Tool
Rectangle Tools
Ellipse Tool
Arc, Chord, Pie Tools
Polygon Tools
Spline Tool



Pointer Tool
This tool is used to Select objects.    An object must be selected before it can be moved, 
rescaled, copied, cut, duplicated, edited, moved forward, moved backward, flipped, rotated, 
grouped, ungrouped, or had any of its attributes modified (such as pen style, pen width, fill 
pattern, font type, font style, or font size).



Text Tool
This tool is used to place a text object on the drawing.    After activating the tool, simply 
point to the entry point on your drawing, then click and release the left mouse button.    A 
text entry dialog box will pop up.    Type the text desired and terminate by pressing the OK or
Cancel buttons.    During text entry you may use the Enter key to start a new line.    You may 
also edit your text using the cursor keys, the backspace key, and the delete key.    To replace 
a block of text, simply highlight the block to be replaced and start typing the new text.

You may initiate edits to an existing Text object in two ways.    Either of the methods below 
will pop-up a dialog box which will allow you to edit the text:

Using the Edit Menu:
To use this method, first select the Text object.    Then choose the Edit Text option on the Edit
Menu.

Double-Clicking:
To use this method simply double-click on the text object using the left mouse button.



Line Tool
This tool is used to draw lines.    After activating the tool, simply point where you desire the 
start of the line, click and hold down the left mouse button, drag the cursor to where you 
desire the end of the line, and release the mouse button.    Arrowheads may be added to line 
objects using the options on the Pen Menu.    The line style or width may be altered using the
Line Style option on the Pen Menu.    In the Constrain mode, lines may only be drawn 
horizontally, vertically, or at 45 degree angles.



Rectangle Tools
There are two tools to draw rectangles, one for regular rectangles and another for rectangles
with rounded corners.    After activating one of these tools, simply point where you desire one
of the rectangle corners, click and hold the left mouse button, drag the cursor to where you 
desire the opposite corner, and release the mouse button.    The rectangle fill pattern may be
altered using the "Fill" option on the Pen Menu.    The line style or width may altered using 
the "Line Style" option on the Pen Menu.



Ellipse Tool
This tool is used to draw ellipses, including circles.    Drawing an ellipse is identical to 
drawing a rectangle that surrounds the desired ellipse.    After activating the tool, simply 
point where you desire one of the rectangle corners, click and hold the left mouse button, 
drag the cursor to where you desire the opposite corner, and release the mouse button.    
The ellipse fill pattern may be altered using the "Fill" option on the Pen Menu.    The line style
or width may altered using the "Line Style" option on the Pen Menu.



Arc, Chord, Pie Tools
Simple curves are drawn as a portion an ellipse.    For more complex curves that make 
changes in direction, you will find the Spline Tool at the bottom of the toolbar more effective. 
There are three tools for drawing simple curves, one for drawing Arcs, which are open 
curves, one for Chords, which connect the endpoints of an arc with a straight line, and one 
for Pies, which connect the endpoints of an arc with two straight lines meeting at the center 
of the ellipse.    Arc, Chord, and Pie objects are initially drawn as one quadrant of an ellipse.    
The endpoints may be extended away from the quadrant boundary when in the Extend 
Curve mode, controllable from the Edit Menu.    Drawing one of these objects is identical to 
drawing a rectangle that surrounds the quadrant of the underlying ellipse.    After activating 
the tool, simply point where you desire one of the rectangle corners, click and hold the left 
mouse button, drag the cursor to where you desire the opposite corner, and release the 
mouse button.    The fill pattern for the Chord and Pie objects may be altered using the "Fill" 
option on the Pen Menu.    The line style or width may altered using the "Line Style" option 
on the Pen Menu.



Polygon Tools
There are two tools to draw Polygons, one for Closed Polygons and another for Open 
Polygons.    After activating one of these tools, simply point where you desire one of the 
polygon vertices, then click and release the left mouse button.    Now move the cursor to the 
next vertex and click and release again.    To finish the Polygon, you must double-click the 
left mouse button or single click the right mouse button on the last vertex.    Closed Polygons
will automatically be connected back to the starting vertex.    After finishing the object, 
Polygon vertices may be individually moved when in the "Edit Poly (or Spline)" mode,    
controllable from the Edit Menu.    The Closed Polygon fill pattern may be altered using the 
"Fill" option on the Pen Menu.    The line style or width may altered using the "Line Style" 
option on the Pen Menu.



Spline Tool
This tool is used to draw Spline Curves.    Spline curves are smooth curves that may contain 
multiple changes in direction, unlike the simple Arcs.    Drawing Splines is similar to drawing 
Polygons.    After activating the tool, simply point where you desire the start of the Spline 
Curve, then click and release the left mouse button.    Now move the cursor to the next 
vertex and click and release again.    To finish the Spline, you must double-click the left 
mouse button or single click the right mouse button on the last vertex.    Although you 
cannot see the resulting curvature until you finish the object, you can go back and edit the 
vertices later, in order to modify the curvature.    After finishing the object, the vertices may 
be individually moved when in the "Edit Poly (or Spline)" mode,    controllable from the Edit 
Menu.    The line style or width may altered using the "Line Style" option on the Pen Menu.



Help on General Topics
Open, Save, or Rename a Drawing
Drawing Objects
Printing a Drawing
Creating and Using Part Libraries
Manipulating Object Descriptions
Transfer to Other Applications

Scrolling
Zooming In and Out
Selecting Objects
Moving Objects
Resizing Objects
Modifying Object Attributes
Making Objects Transparent
Invisible Object Borders
Coloring Objects
Editing Existing Text
Undo Changes
Grouping Objects

Changing the Drawing Size
Changing the Grid Spacing



Open, Save, or Rename a Drawing
To open an existing drawing, use the"Open" option on the File Menu.

To start a new drawing, use the "New" option on the File Menu.

To open a drawing as a parts library, select "Open as Library" from the File Menu.    See 
Creating and Using Parts Libraries for more information on this.

To save your work under the current filename, use the "Save" option on the File Menu.    The 
current filename is usually displayed above the menu.    If "KWIKDRAW" is currently displayed
above the menu, then the current filename is "noname.kwk" by default.

To save your work under a different filename, use the "Save As" option on the File Menu.



Drawing Objects
Your drawings are built up from the "primitive" objects provided by KwikDraw.    These 
"primitive" objects are chosen from the toolbar to the left of the KwikDraw window.    The 
active tool is displayed as a depressed button in reverse video on the toolbar.    When you 
first start KwikDraw, the "pointer" tool is activated.    This "pointer" tool is used to select, 
move, resize, or otherwise edit objects already on the display surface.

To place a new object on the drawing surface, first select the desired object by pressing the 
corresponding button on the toolbar.    Lines, Rectangles, Ellipses, Arcs, Pies, and Chords are 
placed on the drawing surface by pressing the left mouse button, dragging the mouse until 
the desired size is obtained, and releasing the mouse button.    Text objects are placed by 
clicking the left mouse button at the desired location of the upper left corner of the text 
object.    An edit window will pop-up for you to enter your text in.    Polygons and Spline 
Curves are placed by clicking the left mouse button once at each desired vertex.    Double 
clicking or using the right mouse button will terminate the Polygon or Spline. Closed 
Polygons are automatically terminated back at the starting vertex, while Open Polygons are 
not.

Try experimenting, drawing objects is a lot easier to do than it is to explain.    You don't have 
to worry about getting the exact size, aspect ratio, or location of your object just right, since 
any object can be resized,    stretched, or moved after it has been placed.    This is one of the 
major advantages of a Drawing program over a Paint program.

When the "Constrain" option on the Layout Menu is on, the placement of Rectangle and 
Ellipse objects will be constrained to Squares and Circles, respectively.    Arcs, Chords, and 
Pies will be constrained to one quadrant of a circle (as opposed to one quadrant of an 
ellipse), and Line objects will be constrained to horizontal, vertical, or 45 degree slopes 
(including the line segments of Polygon objects).

You may move, stretch, resize, or rotate objects after placing them on the drawing surface.    
To alter an object in any way you must first Select it.    After selecting an object, it may be 
moved by pointing at it again and pressing and holding the left mouse button.    The cursor 
will change to an open hand.    You will then be dragging an outline of the object.    Release 
the mouse button when at the desired location.    Resizing an object is similar except that 
you must point at one of the selection corners.    The cursor will change to a pointing hand.    
You will than be stretching or compressing an outline of the object.    Release the mouse 
button when the desired size is obtained.

You can also change the line style, line thickness, line color, fill pattern, or fill color either 
before or after placing an object on the drawing surface.    With text objects you can change 
the font type, font style, font size, or text color.    With line objects you can add various 
arrowhead styles.    To change one of these attributes after placing the object, you must first 
select the object.    Once an object is selected, you can change any attribute by selecting the
appropriate action from the main menu bar.

The vertices of a Polygon or Spline Curve may be moved individually by selecting the "Edit 
Poly (or Spline)" mode off the Edit Menu.    Arcs, Chords, and Pies are initially drawn as one 
quadrant of an ellipse, but you can reduce or extend the endpoints of these curved objects 
by selecting the "Extend Curve" mode off the "Edit" menu.



Printing a Drawing
To print a drawing, use the "Print" option on the File Menu.

The "Select Printer" menu option allows you to change your default printer by launching the 
Printers portion of the Windows Control Panel.    To change printers, simply double-click on a 
new printer to make it the default.    After selecting a printer, close the Printer Control Panel 
by double clicking in the upper left corner.

The "Print" menu option launches the print popup menu.    You may want to set the printer 
orientation to match the drawing size entered in the "Drawing, Grid Size" dialog box (which 
is launched from the Layout Menu).    To do this, press the "Setup" button on the print popup 
menu.    As an alternative, this printer setup step can also be performed from the printer 
selection control panel at the time that you select a printer.

When printing, KwikDraw will automatically scale the screen drawing to the paper size of 
your printer.



Creating and Using Part Libraries
Creating your own Part Libraries is a very effective way to improve your drawing 
productivity.    KwikDraw's Part Library capabilities provide you with a means of building and 
reusing using your own collection of drawing objects.    Creating a Part Library is as simple as
creating a normal drawing.    The library "parts" are those drawing objects at the highest 
grouping level, and may be placed anywhere on the drawing.    Simply draw the desired 
"part" and group its components so that it forms a single object.    Place a collection of 
logically related "parts," such as electronic symbols or flow chart symbols into a single 
drawing and save it as you would any normal drawing.

When the Parts Library file is opened using the "Open as Library" option on the File Menu, 
the parts will be displayed in a small browse window with a vertical scroll bar.    You may then
scroll through the parts in the library for possible inclusion in your current drawing.    To place
the currently viewed part into your drawing, simply select "Insert from Library" from the 
"Edit" menu.    The browse window may be relocated and resized as desired.

The parts will appear in the browser in the order in which they were drawn in the library file.  
You may change this ordering by using the "Move Forward/Backward" options on the Arrange
Menu while editing your library file.    The objects on top are last in the browse order, while 
those on the bottom are first.    You may wish to overlap the objects in the library file in order
to better see which order they will browse in.



Manipulating Object Descriptions
KwikDraw allows you to attach a text description to any object, including grouped objects 
and their components.    These descriptions may be viewed and edited on-screen or written 
to a text file.    This feature may be used to generate a parts list from your drawing.    There 
are three ways to edit an object description.    Any of the methods below will pop-up a dialog 
box which will allow you to edit the description:

Using the Edit Menu:
To use this method, first Select the object.    Then choose the "Edit Description" option on the
Edit Menu.

Double-Clicking:
To use this method simply double-click on the object with the Pointer tool.    This method will 
not work on Text objects.    For Text objects, double-clicking will edit the text of the object 
instead of the description of the object.

Using the Right Mouse Button:
To use this method, first select the object.    Then press the right mouse button.

To write the object descriptions to a file, select the "Write Descriptions" option on the File 
Menu.    This will open a dialog box that will prompt you for a filename.    If the dialog box is 
closed with the "OK" button, then all object descriptions will be written to the specified file.    
The Notepad text editor that is shipped with MS Windows will automatically be launched and
loaded with the specified file so that you may immediately review the results.    The center 
coordinate of the object is written along with the object description so that you may locate 
an object with a particular description on your drawing.



Transfer to Other Applications
You can copy a drawing, or any portion of a drawing, to any application that supports 
Windows MetaFiles using the Windows Clipboard.    This includes most word processors and 
drawing programs that run under Windows.

To transfer a drawing to another application through the Windows Clipboard:

1) Select the portion of the drawing you wish to transfer.
2) Choose the Copy option on the Edit Menu.
3) Activate the application that you wish to receive the drawing.
4) Choose the Paste option on the Edit Menu of that application.

You should be able to rescale the drawing after it is pasted into the other application.    If the 
application does not support rescaling, then you may be able to rescale the drawing before 
pasting by opening the Windows Clipboard and changing the window size.    The Windows 
Clipboard can be opened from the KwikDraw Edit Menu or from the Accessories Group in the 
Program Manager.

To transfer a drawing to another application as an HPGL file:

You can also transfer your drawing to another application as an HPGL (Hewlett Packard 
Graphics Language) file.    Several DOS and Windows based graphics compatible word 
processors support this format:

1) Select the Printer Setup option from the File Menu.    This runs the Printers setup in the 
Windows Control Panel.

2) Install an HP Plotter as the default printer, printing to a file.
3) Print your drawing using the Print option on the Edit Menu.
4) Import the resulting HPGL file into your other application.



Making Objects Transparent
When one object overlaps another in your drawing, you will often want to make the top 
object transparent, so that you can see through it to the object below.    This is easy to do.    
Simply select the top object and choose the "Fill" option on the Pen Menu.    In the Fill 
Patterns dialog box, check the fill pattern labelled "(none)".

You should note that a transparent object can only be selected by pointing at the boundary 
of the object, whereas an object with any other fill pattern may be selected by pointing 
anywhere in its interior.



Invisible Object Borders
You may wish to remove the solid border of an object that has a visible fill pattern.    To do 
this, simply select the object and choose the "Line Style" option on the Pen Menu.    In the 
Line Styles dialog box, check the line style labelled "(none)".



Coloring Objects
To add color to an object simply select the desired object(s) and choose either the "Fill" or 
"Line Style" Dialog Boxes, which are launched from the Pen Menu.    Use the Fill Dialog Box to
color the internal area of closed objects, such as Rectangles, Ellipses, Closed Curves, or 
Closed Polygons.    Use the Line Style Dialog Box to color the border lines that define any 
object or to color a text object.    These dialog boxes contain three scrollbars for individually 
controlling the red, green, and blue color content.

Note that only solid fill patterns will use Dithered Colors, non-solid fill patterns and line styles
will revert to the closest available Solid Color.



Modifying Object Attributes
To make any changes to an existing object, you MUST first select it.    Once it is selected, 
various object attributes may be altered, as detailed below:

Changing Fill Patterns or Fill Color
When the object is selected, choose the "Fill" option on the Pen Menu.

Changing Line Style, Line Width, or Line Color
When the object is selected, choose the "Line Style" option on the Pen Menu.

Adding or Modifying Line Arrowheads
When a Line object is selected, choose one of the four arrowhead options on the Pen Menu.   
To change the Arrowhead size or style choose the "Arrow Style" option on the Pen menu.

Changing Font Type, Style, or Size
When the object is selected, choose a Font Type or Style on the Font Menu, or a Font Size 
option on the Size Menu.    You can also change font sizes by dragging one corner of the 
selection box, as discussed under "Resizing Objects," above.    KwikDraw will try to maintain 
a reasonable aspect ratio for the font during this process.    You can help out by trying to 
scale the font equally in both dimensions or by turning the Constrain option on.

Flipping or Rotating Objects
When the object is selected, choose one of the Flip or Rotate options on the Arrange Menu.

Changing Polygon Vertices
To change the vertices of a Polygon, you must be in the "Edit Poly" mode, which can be set 
on the EditMenu.    When the Polygon is selected, point at one of the highlighted vertices 
with the Pointer tool, press the mouse button (the cursor should change to a pointing hand), 
drag the vertex to the desired location, and release the mouse button.

Changing Extent of a Curve
To change the extent of an Arc, Pie, or Chord object, you must be in the "Extend Curve" 
mode, which can be set on the EditMenu.    When the object is selected, point at one of the 
curve endpoints with the pointer tool, press the mouse button (the cursor should change to 
a pointing hand), drag the endpoint to the desired location, and release the mouse button.

Changing the Shape of a Spline Curve
To change the shape of a Spline Curve, you must be in the "Edit Poly (or Spline)" mode, 
which can be set on the EditMenu.    When the Spline Curve is selected, point at one of the 
highlighted vertices with the Pointer tool, press the mouse button (the cursor should change 
to a pointing hand), drag the vertex to the desired location, and release the mouse button.



Moving Objects
To move an object, you MUST first select it.    Once the object is selected it will appear with 
"selection dots" at the four corners of a box that surrounds it.    To move the object, point at 
it again, press the left mouse button (the cursor should change to an open hand), drag the 
outline to the desired location, and release the mouse button.



Resizing Objects
To resize an object, you MUST first select it.    To select the object simply point at it and click 
the left mouse button.    If the object is transparent you must point at the line that defines 
the object in order to select it.    Once the object is selected it will appear with "selection 
dots" at the four corners of a box that surrounds it.    To resize the object, point at one of the 
four corners, press the left mouse button (the cursor should change to a pointing hand), 
stretch or shrink the outline to the desired size, and release the mouse button.

To resize a Polygon or a Spline Curve, the "Edit Poly (or Spline)" mode on the EditMenumust 
be turned off.    Likewise, to resize an Arc, Chord, or Pie, the "Extend Curve" mode must be 
turned off.

When the "Constrain" option on the Layout Menu is on, the resized object will be constrained
such that the aspect ratio is preserved.    This means that any change in object size in one 
dimension will be accompanied by a proportionally equal change in the other dimension.



Editing Existing Text
You may initiate edits to an existing Text object in two ways.    Either of the methods below 
will pop-up a dialog box which will allow you to edit the text:

Using the Edit Menu:
To use this method, first select the Text object.    Then choose the Edit Text Object option on 
the Edit Menu.

Double-Clicking:
To use this method simply double-click on the text object with the pointer tool.



Selecting Objects
Normally, when an object is selected, the four corners of a rectangle that surrounds that 
object are highlighted.    There are a few exceptions:

- Line objects are only highlighted at the two endpoints when selected.
- When in the "Edit Poly" mode, the vertices of a Polygon object are highlighted
- When in the "Extend Curve" mode, the endpoints of an Arc, Chord, or Pie object are 
highlighted.

The Edit Poly and Extend Curve modes are discussed under Edit Menu and under Modifying 
Objects.

To Select a Single Object:
Objects are selected using the Pointer Tool.    Closed objects such as Rectangles and Ellipses 
can normally be selected by pointing the cursor anywhere inside the object and clicking the 
left mouse button.    However, if the object is using a transparent fill pattern (the default), 
then you must point near the boundary of the object to select it.    Note that a solid white fill 
pattern is not the same as a transparent fill pattern.    Lines, Arcs, and Open Polygons are not
closed objects, so they also must be selected by pointing near the lines that define them.    If
the object you wish to select is overlapped by another object, click on an exposed portion.

To Select Multiple Objects:
You can select multiple objects in one of two ways.    One method is to simply follow the 
procedure for selecting single objects, except that you hold down the Shift key when 
selecting additional objects.    To use the second method, activate the Pointer Tool, point the 
cursor outside of any object, and press and hold the left mouse button.    This will initiate a 
selection box outline.    Now drag the mouse cursor, drawing an outline around all the objects
that you wish to select.    When finished, release the mouse button.    All objects falling 
completely within the selection box outline will be selected.

To Deselect Only One of Multiple Objects
If you need to deselect one object while keeping others selected, simply point at that object 
and click and release the left mouse button while holding down the Shift key.



Grouping Objects
Multiple objects may be grouped together so that they behave as a single entity with 
regards to operations such as selection, moving, scaling, flipping, rotating, alteration of fill 
patterns, line styles, or font changes.    This feature provides you with a mechanism for 
building a set of drawing components that is more complex than the object types provided 
on the KwikDraw Toolbar.

To group several objects you must first select them.    When the desired objects are selected, 
choose the "Group" option on the Arrange Menu.    Groups of grouped objects can be formed 
to an arbitrary number of levels.    To ungroup a group of objects, first select it and then 
choose the "Ungroup" option on the Arrange Menu.    Note that ungrouping a group of 
grouped objects takes you back only one level instead of all the way back to the base object 
types.



Scrolling
When you are at a zoom level such that the drawing surface is larger than the KwikDraw 
window, you may scroll about the drawing using the scroll bars at the bottom and right 
edges of the KwikDraw window.    There are three ways to use the scroll bars:

Clicking on the arrow buttons at either end of the Scroll Bar:
This method will scroll the window in incremental amounts.    It gives you a fine amount of 
control over the viewing position with visual feedback.    It is, however, the slowest scrolling 
method.

Pressing and moving the thumbscroll button in the Scroll Bar:
This method allows you to rapidly scroll to any arbitrary viewing position.    Unfortunately, 
you will not get visual feedback as you move the thumscroll because the window does not 
update until you release it.

Clicking on the region between the arrow buttons and the thumbscroll button:
This method will scroll the window in coarser increments than clicking on the arrow buttons.  
This is often the best method for panning a drawing quickly with visual feedback.



Zooming In and Out
You may wish to zoom in in order to perform more detailed manipulations on your drawing.    
You may also wish to zoom out in order to view all of a large drawing as a print preview.    
There are 5 zoom levels to choose from on the Layout Menu.    If you wish to focus in a 
certain area of your drawing, simply select an object that is in the general area prior to 
zooming in or out.    The selected object will be centered in the display after the zoom.    This 
will save you from having to search for your area of interest with the scroll bars after 
zooming.    When nothing is selected, the zoom will maintain the current center of the 
display.

You should try to do the bulk of your drawing at the 100% level, and reserve the zoomed in 
modes for detailed placement of objects that have already been drawn.    If you find that you 
require additional drawing area, then it is better to increase the size of your drawing (using 
the "Drawing, Grid Size" selection), rather than attempting to make smaller objects by 
working at a higher zoom level.    See Changing the Drawing Size for more information.



Changing the Drawing Size
You may alter the size of the logical drawing surface on your screen using the "Drawing, Grid
Size" option on the Layout Menu.    You may find, for example, that you need more working 
space.    You can also obtain additional working space by simply doing all your work in one of 
the zoom-in modes.    It is, however, preferable that you work at 100% zoom as much as 
possible, and control your work space size through the "Drawing, Grid Size" dialog box.    One
of the main reasons for this is that you lose placement resolution when working in zoom 
modes over 100% because the "logical pixels" are larger.    The higher zoom modes are also 
slower to work in.

The "Drawing, Grid Size" dialog box allows you to define the number of "logical pixels" in 
each drawing dimension.    A "logical pixel" is equivalent to a screen pixel at the 100% zoom 
level.    Some caveats are in order here:

1) For a printer that uses 8.5" x 11" paper, with a printable surface of 7.5" x 10", it is best 
to maintain a 1.333 (10/7.5) to 1 aspect ratio, with the larger dimension depending on 
whether you intend to place your printer in landscape or portrait modes.    This will result 
in the maximum utilization of paper area.    If you choose some other ratio, KwikDraw is 
nice enough to maintain your aspect ratio on paper, but some of the printable area will 
be unused.

2) KwikDraw will not allow you to define either dimension larger than 2047 logical pixels.    
Placing a number larger than 2047 in any of the boxes on the "Drawing, Grid Size" dialog 
box will cause KwikDraw to disable the "OK" button.

The "Drawing, Grid Size" dialog box includes buttons for four default configurations: 1:1 
Landscape, 1:1 Portrait, 2:1 Landscape, and 2:1 Portrait.    The 1:1 configurations are scaled 
such that the size of objects at 100% zoom on a 13" VGA screen (in 640 x 480 resolution) 
are approximately the same size as the printed output on an 8.5" x 11" sheet of paper with a
7.5" x 10" printing area.    For the 2:1 configurations, objects on screen will be approximately 
half of their printed size.    There is nothing special about these configurations, feel free to 
define your own sizes.    You may find one of the defaults as a useful starting point from 
which you can scale your drawing size up or down.    Please note that these default buttons 
will also reset the Grid spacings as discussed in Changing the Grid Spacing.



Changing the Grid Spacing
You may alter the Grid Spacing using the "Drawing, Grid Size" option on the Layout Menu.    
KwikDraw uses two grid parameters, the Major Grid Spacing, and the Minor Grid Spacing.    
These grid spacing parameters are expressed in logical pixel units, where a logical pixel is 
equivalent to a screen pixel when at the 100% zoom level.    When Grid Snap is on, objects 
are snapped to the nearest pixel in a Minor Grid Position.    When the Grid is displayed, 
however, these pixel Snap locations are only displayed where they coincide with the Major 
Grid Positions.    This enhances redraw time and avoids visual confusion when small grids are
defined with the Minor Grid Spacing.    You may, of course, define the Minor and Major grid 
spacings to be identical, if you wish.

A popular grid setting places Major Grid marks for every 1" of the printed output, and Minor 
Grid marks every 1/8th or 1/10th inch.    Thus for a 7.5" x 10" printable surface and a 600 x 
800 logical pixel size, a typical Major Grid would be 80 pixels (800 divided by 10).    Note that
the other dimension also works out to 80 pixels (600 divided by 7.5).

Please note that the Major Grid Spacing MUST be some multiple of the Minor Grid Spacing.    
KwikDraw will not allow a combination of grid spacings that violate this rule.    If the grid 
spacings do not conform, then KwikDraw will disable the "OK" button on the dialog box.

The "Drawing, Grid Size" dialog box includes buttons for four default configurations: 1:1 
Landscape, 1:1 Portrait, 2:1 Landscape, and 2:1 Portrait.    These buttons are discussed in 
Changing the Drawing Size.    Be aware, however, that these buttons will reset the Major and 
Minor Grid Spacings to 80 pixels and 10 pixels, respectively.    In the 1:1 configurations, this 
corresponds to a Major Grid for every inch on the printed output, with a Minor Grid every 
1/8th of an inch.    In the 2:1 configurations, this corresponds to a grid pattern that is twice as
dense.    Feel free to define your own grid pattern regardless of whether you are using one of 
the default drawing sizes.


